Naming Conventions

So do you have naming conventions for your controls and variables?  If so is it documented and do you ever break those rules?

If you don’t have naming conventions do you think it makes any difference in the quality of your code?

I’ve never been a big fan of Hungarian Notation.  Do you use it?  Have you used it in other languages?  Why is it good/bad?

Anything I missed or you think I got wrong in the column?

OPC (Other Peoples Code) Column

This issue’s topic was about dealing with OPC (Other Peoples Code) as a consultant.  It’s a difficult thing, sometimes, to say no to a potential client based on your first (and sometimes second) look at their code.  While I always regret saying no to paying work I’m always helpfully reminded by my wife why it’s a good idea NOT to take some work.  She does, after all, have to listen to be complain about it!

I’ve certainly learned a few habits over the years by trying to decipher someone else’s code.  Naming conventions are the number one problem I see with most OPC projects that I see come my way and I spend a fair amount of time deciphering what the name of the controls and variables *should* be.

What about you?  What horror stories can you share?

September/October Edition of RB Developer

The BKeeney Briefs column was about debugging and why it’s so important to learn how to debug.  Do you have any other thoughts on the importance of debugging?  Did I miss something?

The Formatted Text Control by True North Software is an excellent editfield replacement and it has some very powerful features such as being able to create your own custom objects that are read/write in its XML format.  What’s your favorite feature?  What is it lacking that I didn’t hit in the article?  How would you compare it to other editfield replacements?

Marc Zeedar has an excellent article on variable naming that’s worth reading.  To add to his article, I’d say that control naming is something I’ve seen way too many RB developers mess up on.  Using the RB defaults names (such as Pushbutton1, Pushbutton2, and so on) doesn’t help you very much when you see it in code.  In my opinion, if you have to go back to the layout to determine its function then you’ve messed up!  Using control names like pbOK and pbCancel make it explicitly clear in code what you’re talking about.  Agree?  Disagree?